viernes, 9 de agosto de 2013

Touchpad y Debian

Un saludo, hace tiempo que no escribo nada por aquí. Dejé de hacer pruebas y me quedé con lo que tenía. Por varias razones, que el que esté medio enterado de la situación actual, he pensado en que ya era hora de cambiar a Debian.

En el ordenador en el que hacía las pruebas (Acer Aspire One 255D) tengo instalado Ubuntu 12.04 con Gnome3 y estoy encantado. Para otras cosas que tengo la obligación de hacer, se me quedaba corto.

Actualmente tengo un Asus A55V i7. Como no puede ser de otra forma venía con el Windows 8 preinstalado al que le añadí Ubuntu. Gracias a la ayuda de +NovatillaSku, +Yoyo Fernández y +Michel en la red logré instalar ambos sistemas operativos. No es algo sencillo y hay que hacer muchos pasos. Cosas que tiene Microsoft y esa imposición de usar BIOS UEFI.

Me he quedado con Ubuntu y el poco deseable, para mí, entorno gráfico Unity. Se quedaba pensativo en más de una ocasión y por un fallo que me costó encontrar, ve veía obligado a utilizar Windows 8.

Problema: Una aplicación que trabajaba con java era imposible utilizarse en Ubuntu. Al parecer y tras mucho dar vueltas, se trataba de una incompatibilidad entre versiones de java y que en se soluciona:

         - Ubuntu: instalando Complemento Java Icedtea
         - Debian: instalando sólo la versión más actual de Java Icedtea y eliminando el resto.

Solucionado esto, la decisión estaba tomada, de todas formas. Decidí ir a Debian. Pero me he encontrado con varios problemas.

  1. ¿Cuál debo descargar?
  2. ¿Cómo instalarlo?
  3. ¿Qué me voy a encontrar?
1.- Para responder a éste problema es rápido leyendo en la wiki, que casi ninguno leemos. Aunque se trata de un Intel Core i7 64bits no se te ocurra bajarte otra imagen de disco que no sea AMD64.

2.- Parece fácil, sólo debo quemar la imagen de disco, meterlo y listo. Pues no, no es así. Para la instalación de Ubuntu junto a Windows 8 se debió tocar todo así que no me reconocía nada que no fuera lo que ya estaba. Tenía que introducir el DVD con la versión para instalar de Debian AMD64 y luego apagar el equipo. Sí, con el Sistema Operativo encendido. Luego al iniciar pulsando la tecla "supr" en mi caso, entrar en la BIOS y cambiar la opción de arranque. Sí, ahora sí. He probado con versiones de 32 bits y no hay manera de que sea reconocido. A continuación salimos guardando y proseguimos la instalación.



3.- Pues me he encontrado un sistema operativo exactamente igual, que el Acer Aspire One con Gnome3. Me ha encantado y trabajando más estable. Pero se me ocurrió apagar el PC. Cuando volví a iniciarlo, no había manera. Error al arrancar. No recordaba que el sistema estaba configurado para un modo especial de uso de UEFI para poder usar de manera conjunta tanto el Windows 8 como Ubuntu. Esta versión especial buscaba el grub al que se refería y ya no estaba así que nada. No arrancaba.

¿Me daba una bofetada por hacer algo que no debía haber hecho? :-P No, inicié la BIOS y volví a la configuración de fábrica. No recordaba que esto activaba la UEFI de fábrica y yo tan feliz, pensé que ya estaba arreglado y reinicié. Pues nada, una pantalla roja me avisó que no tenía nada que hacer.



Volví a iniciar la BIOS y desactivé esta opción y ya podía utilizar el sistema operativo sin mayores problemas.

Problema que no he sido capaz de solucionar (y eso que me he leído la wiki y soluciones propuestas por varios amigos) el uso normal del touchpad. Se trata de un touchpad donde los mismo botones forman parte de la parte táctil. Pues bien, reconoce sólo el touchpad como si sólo dispusiese de un único botón. Pierdo por completo la funcionalidad del botón secundario.

He conectado un ratón al puerto USB y funciona a la perfección. Así que ni modificando manualmente el 50-synaptics.conf ni intentando hacerlo a través del dconf-editor.




Muchas gracias por las ayudas de los miembros de Diaspora*, Identi.ca y SpotBros que me están ayudando.

Al final, y siguiendo las instrucciones de otra página de la wiki mandada por un compañero de SpotBros he dado con la tecla. Que por cierto, acaba de empezar un blog que tiene buena pinta.

$ su
$ contraseña
$ nano /usr/share/X11/xorg.conf.d/50-synaptics.conf

Colocamos como comentario (que cada línea comience con #) todo lo que aparezca y que no se corresponda con ésto.

Section "InputClass"
        Identifier      "Touchpad"                      # required
        MatchIsTouchpad "yes"                           # required
        Driver          "synaptics"                     # required
        Option          "MinSpeed"              "0.5"
        Option          "MaxSpeed"              "1.0"
        Option          "AccelFactor"           "0.075"
        Option          "TapButton1"            "1"
        Option          "TapButton2"            "2"     # multitouch
        Option          "TapButton3"            "3"     # multitouch
        Option          "VertTwoFingerScroll"   "1"     # multitouch
        Option          "HorizTwoFingerScroll"  "1"     # multitouch
        Option          "VertEdgeScroll"        "1"
        Option          "CoastingSpeed"         "8"
        Option          "CornerCoasting"        "1"
        Option          "CircularScrolling"     "1"
        Option          "CircScrollTrigger"     "7"
        Option          "EdgeMotionUseAlways"   "1"
        Option          "LBCornerButton"        "8"     # browser "back" btn
        Option          "RBCornerButton"        "9"     # browser "forward" btn
        Option          "EmulateTwoFingerMinZ"  "35"
        Option          "EmulateTwoFingerMinW"  "8"
 EndSection

Guardamos y podemos probar si funciona correctamente sin necesidad de tener que apagar y encender. Así que probamos:

$ modprobe -r psmouse
$ modprobe psmouse proto=imps

Para que se active cada vez que iniciamos el sistema debemos hacer lo siguiente:

$ nano /etc/modprobe.d/touchpad.conf

Donde escribimos:

options psmouse proto=imps


Actualizamos e instalamos

$ aptitude update
$ aptitude install xserver-xorg-inputs-synaptics


Guardamos y pasamos a editar el siguiente.

$ nano /etc/X11/xorg.conf

Section "Module"
    Load           "synaptics"
EndSection
 
Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "synaptics"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
Option "TapButton1" "1"
Option "SpecialScrollAreaRight" "true"
Option "VertEdgeScroll" "true"
Option "VertTwoFingerScroll" "true"

EndSection
 
 
 
Ya sólo queda activar el demonio y listo.

$ nano /etc/X11/Xsession.d/98x11-syndaemon

/usr/bin/qsynaptics -r
/usr/bin/syndaemon -d -t -k -i 1 

Guardamos y con esto es suficiente. Si alguien ha tenido este problema espero que le sirva.

3 comentarios:

Boris dijo...

Es la primera vez que veo un trackpad sin botones. Eso no lo sabia. Por desgracia no puedo ayudarte. Pero estoy mirando por internet y si veo algo te lo paso.

Anónimo dijo...

Muchas gracias por publicar la solución! Llevaba dos días intentando y no me resultaba.
Has sido de mucha ayuda :)

Victor Gabriel Arjona Alonso dijo...

Un comentario de diciembre y yo ni me había dado cuenta. Disculpa.

Esta entrada me ha venido bien ahora. He instalado Elementary OS y tenía el mismo problema. La velocidad mínima la he subido a 0,8 y la máxima a 1,9 y me va mucho mejor, no tan sensible.